User Interface

The intuitive and straightforward design of ContourTrace allows fast image processing with high precision in no time. The conversion from raster graphics to vector graphics follows a plausible workflow to the result that is required. Each step is further defined as ‘operator,’ which inherits multiple functionalities (for further information, see ‘Operators’).

ContourTrace Menu Overview

The modular architecture of ContourTrace allows an individual adaption to the current needs of your workflow. The default menubar provides multiple functions regarding the usability or informative additional sources.

_images/contourTraceOverview_menu.png

1. Main menu declaration and basic functionality

The main menu inherits multiple functionalities to provide orientation in the ContourTrace application.

Title

Description

File

The File-Menu inherits the functionalities Open, Reload, Save (for further information see table below), as well as Exit to close ContourTrace manually.

Extras

The Extras-Menu contains the Camera Calibration functionality (for further information see table below).

Options

The Options-Menu inherits the License Manager, the possibility to Check for ContourTrace updates, as well as the adaption of the displayed Language and Theme.

View

The View-Menu provides the adaption of the ContourTrace interface to the required needs, by selecting / deselecting operators, defining the Corner layout and Ruler layout structures, which allows a high level of individuality. The reset to the default interface can be found here as well.

Help

The Help-Menu contains references to the KUHN ENGINEERING YouTube-Channel, the Website (for further information see table below), the About-Information including the Software Disclaimer, and the possibility to visualize the available MAC-Addresses of the corresponding device.

In addition and below the main menu, ContourTrace provides quick access for the most common functionalities.

Icon

Action

Description

_images/openFile.png

Open (Load) image from directory

This action opens a file explorer to define a specific image, which will further be processed in ContourTrace.

_images/reloadFile.png

Reload the image from hard disk

This action reloads the original image from the hard disk. This is a convenient way to edit the image in parallel in another graphics program.

_images/saveOrExport.png

Save and export graphic to individual location

This action save the edited / transformed input image to a defined location. The location and file name can be specified through an opening file explorer.

_images/camera.png

Camera calibration

This action accesses the camera calibration operator (Pro-Version).

_images/web.png

Reference to website

This action refers to the KUHN ENGINEERING website for further information.

_images/youtube.png

Reference to youtube channel

This action refers to the KUHN ENGINEERING youtube channel, which provides tutorials and help for the usability of ContourTrace.

2. Operators’ and View selection

By using the provided dropdown menus, ContourTrace adapts the view according to the selected requirements. A distinction is made here between Image processing and Vector processing.
HINT: There is no correlation between the operator’s selection and the selection within the dropdown menus. The dropdown selection specifies the current view within the visualization area. The currently selected operators remain unaffected.

3. Usability Toolbar

ContourTrace now provides the separation between several modes during graphic processing. The following table contains a summary of the specified functionalities.

Icon

Action

Description

_images/cursor.png

Select with left Mouse click

This mode limits the functionality to selecting single elements with the left mouse button. Movement is not possible.

_images/selection.png

Select with rubberband

This mode limits the functionality to selecting multiple elements by creating a ‘rectangle’ which selects every element that is crossed or already contained. Movement is not possible.

_images/open-hands.png

Draw View with left mouse button

This mode provides the movement within the current view by using the left mouse button. Single selection of elements is still possible.

_images/zoom.png

Zoom in/out with left mouse button

This mode provides precise zoom in and zoom out functionality by using the left mouse button and dragging up/down.

_images/ZoomToFit.png

Zoom to fit all elements in graphics view

This mode resets all zoom settings and adapts the image size to the available view size.

4. Application scaling

ContourTrace allows an individual scaling of the graphic by defining a single distance within the view. This scaling factor increases the precision and additional functionalities, e.g., Creating an offset from a contour. The resulting factor is calculated considering the image size, the defined distance, and the selected unit. A dialogue is visualized by clicking on the available Icon, which requests individual input from the current user.

_images/scalingFactor.png

Simply define the distance between two coordinates by a simple mouse click and let ContourTrace calculate the required values to scale the complete graphic. The only input necessary is a known distance between the marked coordinates.

ContourTrace Structure Overview

The main structure of ContourTrace follows a unique design aligned to an understandable and straightforward workflow.

_images/contourTraceOverview_structure.png

5. Individual Dockwidget View

The Dockwidget view inherits the individual functionality of the currently active Operator. For further information on the specific content, see the section Operators.

6. Operator workflow (Default)

The Operator workflow signalizes the active processes that are involved within the defined graphics processing pipeline. The corresponding Operator is set to active by clicking on a button, and the view switches to the selected Operator’s view.

7. Ruler View (Default)

The Ruler View improves the precision in the graphics processing phase by providing a set of rules for size determination. The current mouse position is signalized by straight red lines that adapt their location dynamically.
Default settings apply a ruler located on the top and left. The main menu (see 1. Main menu declaration and basic functionality) can be extended to the bottom and right.

8. Graphics View

The graphics view can be described as the main operation component. Depending on the active Operator, multiple functions can be applied to the current visualized graphic.